Ce forum est maintenant fermé, seule cette archive statique reste consultable.
  FORUM Rue-Montgallet.com
  Programmation
  Html

  Lecteur WMP dans une page HTML

Bas de page
Auteur Sujet :

Lecteur WMP dans une page HTML

n°11723
firew4rrio​r
Profil : Jeune recrue
Posté le 03-03-2005 à 10:55:37  
 

Salut à tous,
 
Je voudrais intégrer le lecteur WMP dans une page HTML afin de pouvoir lire des mp3.
Voiçi le code que j'ai inséré dans une page mais hélas le lecteur apparaît bien dans la page mais le bouton play reste grisé  :cry:  
 
<object  
classid="clsid:6BF52A52-394A-11D3-B153-00C04F79FAA6" width="320" height="45"  
id="mediaplayer1">
  <param name="Filename" value="02 Dixo.mp3">
  <param name="AutoStart" value="True">
  <param name="ShowControls" value="True">
  <param name="ShowStatusBar" value="False">
  <param name="ShowDisplay" value="False">
  <param name="AutoRewind" value="True">
  <embed  
type="application/x-mplayer2"
pluginspage="http://www.microsoft.com/Windows/Downloads/Contents/MediaPlayer/"
width="320" height="290" src="/download/02%20Dixo.mp3"
filename="02 Dixo.mp3" autostart="True"  
showcontrols="True" showstatusbar="False"  
showdisplay="False" autorewind="True"> </embed>
</object>
 
 
Quelqu'un aurait-il la solution ??
 
Merci de votre aide  :)


---------------
Qui fait le malin tombe dans le ravin
mood
Pub
Posté le 03-03-2005 à 10:55:37  
 

n°12472
aztech
Profil : Jeune recrue
Posté le 08-04-2005 à 22:07:28  
 

Salut  
en fait le bouton est grisé car il ne trouve pas le fichier
 
essaye comme cela :
 
<p class=MsoNormal><object classid="CLSID:6BF52A52-394A-11D3-B153-00C04F79FAA6"
 name=WindowsMediaPlayer1 id=WindowsMediaPlayer1 width=320 height=290>
  <param name=URL value="/download/02%20Dixo.mp3">
  <param name="AutoStart" value="True">  
  <param name="ShowControls" value="True">  
  <param name="ShowStatusBar" value="False">  
  <param name="ShowDisplay" value="False">  
  <param name="AutoRewind" value="True"
 </object>
 
Voila à +

n°12473
lukefab
meuh
Profil : Habitué
Posté le 08-04-2005 à 23:04:06  
 

Et si t'as pas WMP, y se passe quoi?

n°12474
aztech
Profil : Jeune recrue
Posté le 09-04-2005 à 00:18:09  
 

Ce code utilise les ActiveX donc il ne fonctionnera pas avec tous les navigateurs(ne marche pas avec Firefox par exemple).
En fait j'ai commis une erreur le code est plutot cela :
 
<p class=MsoNormal><object classid="CLSID:6BF52A52-394A-11D3-B153-00C04F79FAA6"  
 name=WindowsMediaPlayer1 id=WindowsMediaPlayer1 width=320 height=290>
 
  <param name=URL value="/download/02%20Dixo.mp3">
 
  <param name="AutoStart" value="True">  
  <param name="ShowControls" value="True">  
  <param name="ShowStatusBar" value="False">  
  <param name="ShowDisplay" value="False">  
  <param name="AutoRewind" value="True"  
 
 <embed    
type="application/x-mplayer2"  
pluginspage="http://www.microsoft.com/Windows/Downloads/Contents/MediaPlayer/"  
width="320" height="290" src="/download/02%20Dixo.mp3"  
filename="02 Dixo.mp3" autostart="True"    
showcontrols="True" showstatusbar="False"    
showdisplay="False" autorewind="True"> </embed>  
</object>  
   
Car si le navigateur ne trouve pas le plugin il va le chercher sur l'adresse indiqué aprés " pluginspage".
 
voila  
 
 

n°12476
lukefab
meuh
Profil : Habitué
Posté le 09-04-2005 à 12:36:40  
 

aztech a écrit :

Ce code utilise les ActiveX donc il ne fonctionnera pas avec tous les navigateurs(ne marche pas avec Firefox par exemple).


 
Cool!  :sol:


---------------
Opera 8.51 pour Windows, Linux, FreeBSD, Solaris, Mac OS X.
www.opera.com , c'est bon et sans morceau de pub dedans, mangez-en.
Un pingouin aux pommes ?
n°12477
ollone
Part of the 'One brothers
Profil : Vieux de la vieille
Posté le 09-04-2005 à 13:04:23  
 


:lol: C'est beau l'informatique :D


---------------
C'est naturel que les filles soient plus belles, et les garçons plus cons ^^ [un peu bonobo sur les bords]
n°13580
NeuNeu78
Profil : Jeune recrue
Posté le 08-06-2005 à 18:59:14  
 

J'ai essayé chez moi mais sa marche pas je clique sur le bouton play mais y'a rien qui se lance c'est normal? je vous met le code que j'ai un chouia modifié:
 
 
<p class=MsoNormal><object classid="CLSID:6BF52A52-394A-11D3-B153-00C04F79FAA6"  
 name=WindowsMediaPlayer1 id=WindowsMediaPlayer1 width=320 height=290>
 
  <param name=URL value="/musique/Good%20Charlotte-%20The%20Young%20And%20The%20Hopeless-02%20-Another%20Loser%20Anthem-certifi%e9%20par%20buzz363.mp3">
 
  <param name="AutoStart" value="True">  
  <param name="ShowControls" value="True">  
  <param name="ShowStatusBar" value="False">  
  <param name="ShowDisplay" value="False">  
  <param name="AutoRewind" value="True"  
 
 <embed    
type="application/x-mplayer2"  
pluginspage="http://www.microsoft.com/Windows/Downloads/Contents/MediaPlayer/"  
width="320" height="290" src="/musique/Good%20Charlotte-%20The%20Young%20And%20The%20Hopeless-02%20-Another%20Loser%20Anthem-certifi%e9%20par%20buzz363.mp3"  
filename="02 Dixo.mp3" autostart="True"    
showcontrols="True" showstatusbar="False"    
showdisplay="False" autorewind="True"> </embed>  
</object>  
 
Voila et puis c posible d'avoir juste la bar de play and stop si oui comment merci.
Je sais que c'est pas mon forum mais vu que sa traitre du meme sujet je prefere poster la merci d'avance!

n°14105
rreemmyy
Campeur
Profil : Membre
Posté le 09-07-2005 à 02:32:51  
 

Fais attention, c'est illégal de diffuser des mp3 commerciaux sur son site :)

n°14177
oxymure
Profil : Jeune recrue
Posté le 14-07-2005 à 13:50:07  
 

Neuneu78, t'es un "génie", ton code fonctionne à la fois dans Firefox et dans IE !!!!!

n°15352
Armenak
Profil : Jeune recrue
Posté le 30-11-2005 à 22:28:28  
 

Rien ne marche...
Par contre ça oui!
 
<object
 classid="CLSID:22D6f312-B0F6-11D0-94AB-0080C74C7E95"
 codebase="http://activex.microsoft.com/activex/controls/mplayer/en/nsmp2inf.cab#Version=6.4.7.1112" type="application/x-oleobject"
 width="640"
 height="530" align="middle"
 standby="Chargement en cours" id="objMP">
              <param name="Filename" value="http://arapian.com/images/video/partirdela.wmv" />
              <param name="AnimationAtStart" value="false" />
              <param name="AutoSize" value="true" />
              <param name="AutoStart" value="false" />
              <param name="Balance" value="0" />
              <param name="CanSeekToMarkers" value="true" />
              <param name="EnableContextMenu" value="false" />
              <param name="EnableTracker" value="true" />
              <param name="Loop" value="false" />
              <param name="ShowAudioControls" value="true" />
              <param name="ShowControls" value="true" />
              <param name="ShowDisplay" value="false" />
              <param name="ShowGotoBar" value="false" />
              <param name="ShowPositionControls" value="false" />
              <param name="ShowStatusBar" value="true" />
              <param name="ShowTracker" value="true" />
              <param name="TransparentAtStart" value="true" />
              <param name="Volume" value="-500" />
              <embed
 src="http://arapian.com/images/video/partirdela.wmv"
 width="640"
 height="530"
 autostart="true"
 loop="false" align="middle" type="application/x-mplayer2" pluginspage="http://www.microsoft.com/Windows/MediaPlayer/"
 id="objMP"
 animationatstart="true"
 autosize="true"
 balance="true"
 canseektomarkers="true"
 enablecontextmenu="true"
 enabletracker="true"
 showaudiocontrols="true"
 showcontrols="true"
 showdisplay="true"
 showgotobar="true"
 showpositioncontrols="true"
 showstatusbar="true"
 showtracker="true"
 transparentatstart="true"
 volume="-500"> </embed>
            </object>
 
 

n°15368
lukefab
meuh
Profil : Habitué
Posté le 02-12-2005 à 13:34:00  
 

rreemmyy a écrit :

Fais attention, c'est illégal de diffuser des mp3 commerciaux sur son site :)


si l'on n'a pas reçu l'accord de l'auteur/interprète/maison de disque (rayez la mention inutile)


---------------
Opera 8.51 pour Windows, Linux, FreeBSD, Solaris, Mac OS X.
www.opera.com , c'est bon et sans morceau de pub dedans, mangez-en.
Un pingouin aux pommes ?
n°15747
Bibibi
Profil : Jeune recrue
Posté le 25-01-2006 à 00:30:15  
 

Dites, pour moi, mettre le lecteur sur la page html et le faire fonctionner, ça marche, mais seulement si la vidéo est dans le même dossier que la page ou bien dans le dossier parent (ou si je marque un chemin absolu, bien sûr). Si je remonte de 2 niveaux(../../), impossible de lire la vidéo.  
Quelqu'un sait-il pourquoi?

n°19157
badau
Profil : Jeune recrue
Posté le 21-01-2008 à 10:01:53  
 

J'ai ( en bas du Player) Selection 1 en bas du film, comment remplacer Sélection 1 par un nom significatif ?

  FORUM Rue-Montgallet.com
  Programmation
  Html

  Lecteur WMP dans une page HTML

© 2000-2018 Forum.rue-montgallet.com - Tous droits réservés